Compatibilité

JetFlash 380

Numéro d'article Transcend
Transcend Elite App Download

*Android version 4.0 or later.

*The product is not supported on Windows phones.